[SOLVED] Correct answer but phone says "wrong"

I have an ongoing and intermittent issue where the player answers correctly but their phone says “WRONG”. When I go into the rankings, I can see where they did answer correctly and points were awarded. I can provide details if needed.


We get that frequently too.
Go into activity and find the answer and the player and it will say either yes or no as to their answer. It’s time consuming though…


Yes, I can advise the player that they received their points but this bug causes concern with our players.


This frequently happens to us too.

1 Like

Hi @doc.proctor.sc,

This is a known interface display bug that very occasionally happens when our platform gets really bogged down with games and players (e.g. hundreds of simultaneous games and tens of thousands of simultaneous players across the app). While the incorrect label on the Mobile View doesn’t affect scores, it can misinform players. Our team is currently working on resolving this issue ASAP and will be sure to keep you informed of any updates to this ticket.

Thank you for the update.

Any update on this bug?

1 Like

Good morning. It seems that this bug is getting worse. I had several instances of this issue at last nights gig. Please fix this! It is becoming embarassing!

We’re now actively trying to solve this. It will be helpful to have some extra details from those who are experiencing it. Can you answer these questions:

  • For participants who experience this, does it happen on every question on their device? Or does it seem to be intermittent?
  • What types of devices is it occurring on? iPhones, Andriods, older phones?
  • When it happens, are you going through a normal process of 1) Launch new question 2) Allow time for answering 3) Show live answers 4) Show correct answer? With plenty of time between these? Or are you flipping through questions in a review and/or going through the process much faster?

We’ve narrowed down what could be causing this, but the above information will help us solve it for good.

I wish I had better news, Ross, but it is intermittent. I have tried to find a cause but it just randomly occurs. I have seen it happen on both iPhone and Android. The age of the phone does not seem to matter. I am going through the process at a normal pace.

Thanks for your help!

1 Like

Good news! After a few days of intense code inspection, we are finally able to reproduce this issue in development and fix it!

We’re about 95% sure that this fix is the solution to what’s causing this. Our team is working on this patch and we’ll have this out in the next day or two and will report back once it’s published.

That’s awesome, Ross! Thanks!

I’m very happy to report that this bug is now solved and published. You can read about the details in our latest January 2023 Product Updates blog post.